Get Concrete Quality Software

Installer for the latest version (v1.90.0)

Start your 1-month free trail now!

 

 

CQ All-in-One Installer

Changes in the latest version

The new version 1.90.0 includes many performance improvements and new features, such as:

  • Automatic updates! This version is the last one you’ll need to install, from now on Concrete Quality will update itself automatically.
  • General fixes and various upgrades.

Prerequisites

Administrator privileges needed
You will need administrator privileges for your computer to complete the installation, specially if any of the required prerequisites need to be installed. Check with your IT department if you need special permissions to install. You will find valuable information in the Installation tutorial.

If your Windows version is not compatible, install the latest Windows Service Pack. Don’t install or try to run the application within a network (shared) drive or folder.

If you have problems installing or running the application, please contact us.

Updating an older version

All users with an older version must upgrade it to continue using the subscription services and benefit from the new features. You can download the update with the link above (same operation as a new installation). You will not lose existing information, but we recommend that you synchronize with the server before performing any updates.

Troubleshooting

In case you cannot install Concrete Quality, please try to install the necessary component :

  1. .NET Framework: version 4.5.1

This installer includes the minimal required pre-requisites for the application to work: .NET Framework 4.5.1. It will be installed automatically if necessary, though its installation may fail in some cases. You will not be able to run Concrete Quality if this component is not correctly installed.

 

You require administrator privileges for your computer to install these components. The firewall must not reject incoming and outgoing connections for the endpoint https://cqserver.concrete-quality.com/PROD/syncro.svc. Ask your IT department for help regarding this.

 

If your Windows version is not compatible install the latest Windows Service Pack. Newer Windows versions include these components as a part of the standard build.

 

If you still have problems installing or running the application, please contact us.

Compatible operating systems

The Concrete Quality software package works under all Windows versions that support .NET Framework 4.5.1 or higher:

Download for Windows onlyWindows 10; Windows 8 & 8.1; Windows 7; Windows 7 Service Pack 1; Windows Server 2003 Service Pack 2; Windows Server 2008; Windows Server 2008 R2; Windows Server 2008 R2 SP1; Windows Vista Service Pack 1; Windows XP is no longer supported.

Starting at Windows 8 the .NET Framework component is included as standard, so it’s not necessary to install it to run Concrete Quality. It might still be necessary to install the SQL Server CE 4.0 component.

 

The Concrete Quality package is not compatible with Mac or other operating systems (Unix, Linux, etc). For mobile access, you have the Fiel Test feature.

Download installation requirements

In order to run the Concrete Quality package two components are needed, which extend Windows functionality. These components are provided directly by Microsoft and are included in the full installer. They will be installed only if necessary.

Here you’ve got the link for the individual component installer, in case you need it.

 

.NET Framework

To run Concrete Quality you need the .NET Framework 4.5.1 or higher. You can find it here:

Download Microsoft dot .NET version 4.0 4.5.NET Framework 4.5.1 (both 32 & 64 bits)

  • Free download without registration
  • Unlimited functionality
  • No cancellation required
  • Pay only for optional services
  • FREE! Expert plan trial for one month

Create a new user

To create a new user open the application and in the Login screen go to the panel on the right named “I’m new here” (light blue color).

Concrete Quality Sign up for free